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Prod Lx 
Created by Tom Bexon (tom@tb-lx.com) 

 

Installation 

Auto-Installation 

To install, Download the Prod Lx.zip file and save it somewhere on your hard drive. 
Unzip this and inside you should find this manual, and a ProdLx.vwlibrary file.  

Open Vectorworks Go to: Tools>Plug-ins>Plug-In Manager. Once the Plug-in Manager 
window has opened click Install. Navigate to wherever you have saved the Prod 
Lx.vwlibrary file, and select the .vwlibrary file. Vectorworks will then automatically install 
the plug ins, and work space. Once the installation operation is complete you will need 
to restart Vectorworks. 
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Adding the tools to your workspace 
In order to use the tools within this package you must first add them to your workspace. 
When you run the installation a workspace with all the tools already in it is automatically 
created. To activate this workspace go to: Tools>Workspaces and select ‘Prod Lx.  

 

 

 

 

 

 

 

 

 

 

However if you already have tools from 
another workspace (Such as AutoPlot), you 
may want to combine these tools into an 
existing workspace. To do this go to: 
Tools>Workspace>Edit Current Workspace.  

The way this window works is you drag 
commands from the left and deposit them 
under menus on the right. The commands are 
separated into two types: Menu Commands 
and Tools. 

Menu Commands are commands that sit up in 
your menu tool bar, tools are commands that 
sit in your tool palette. 

To add a new menu command drag the top 
command, ‘New Menu’ across to the right. 

I recommend you create a new menu called 
Prod Lx and add all the commands under the 
sub menu Prod Lx on the left, as shown in this 
Screenshot.   
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Next we need to add 
the commands that sit 
in the tool palette. 
WITHIN the Palette tool 
set create a new Tool 
Set NOT Tool Palette.  

Then again drag all the 
tools under the Prod Lx 
sub menu over to the 
right, as shown here.  

 

 

 

 

Registration 

To use the plugins within this package you must first register them. If you haven’t done 
so already go to TB-LX.com/licences/ and purchase the appropriate license. Once you 
have purchased a license you should receive an email with your license. (this will be a 
.crt file attached to the email). Once you have your license, download and save it 
somewhere, I recommend saving it within your Vectorworks user folder. (which can be 
accessed by going: Options -> Vectorworks Preferences -> User Folders and then 
clicking Explore to open an Explorer or Finder window, depending on your operating 
system.  
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Within Vectorworks run Prod Lx -> Register Products command.  

You should see a window like this. Enter the email address you registered 
the product with, and then click “Select License Key” and navigate to 
wherever you saved the license, and select that file. You should then get a 
pop up confirming that the license has been validated. When you click Ok 
the path to said License file will be saved so that you don’t have to re-
register you’re license every time you open Vectorworks.  

A cautionary note: If you move your license file you will have to re run the 
register product command, because Vectorworks will no longer be able to 
find you’re license file. 

Request a Trial 
Want to try Prod Lx before you buy? We offer free 90 day trials. If you 
require longer than 90 days I’m happy to accommodate, please email 
tom@tb-lx.com to discuss further. 

To request a 90 Day Trial follow the installation instructions above to 
install Prod Lx normally, then once you have successfully added the 
plugins to your workspace, run the Product Registration command, and 
click the ‘Request Trial’ button. 

You will be presented with a dialog where you can fill in: 

Your email address: This should be a valid email you have access to, as 
you’re trial license will be sent to this address.  
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Your Seat ID: This is the last 6 characters of you’re Vectorworks serial code, and is 
unique to you’re license.  Please note only one trial license can be registered per Seat 
ID. To view you’re license go to: Tools > Options > Vectorworks Preferences > Session 
and click on Serial Numbers. 

 

First Name and Last Name: The name you would like the license 
to be assigned to. 

 

Once you have filled in all the requisite information click Request 
Trial button, and you will see a pop up that will tell you whether 
you’re trial has been successfully created or not. You should 
receive an email with you’re Trial license shortly after.  
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Tools 

Below is a description of each tool/ Menu Command. 

 

Insert Loom – Inserts a Loom note. The colour and type of loom can be changed from 
the OIP menu, and all necessary fields can be filled in from the OIP. If no record called 
“Loom Note” is present, when activated, this tool will automatically create the record and 
attach to every Loom Note object. All Fields are automatically filled in and updated 
when changed in the OIP.  

If the Loom is a staggered Loom (e.g the cables are different lengths) the user can 
specify their specific lengths by typing the label followed by “/” and then the length. So if 
I wanted to a 25m Multi labelled “AA” I would type into Multi 1 field “AA / 25m”. This will 
automatically fill in the requisite fields within the “Insert Loom Note” record format for 
easy exporting. 

 

 

 

 

 

The Separator Character can be changed within the Preferences Menu. 

You can change the Multi Type using the Multi Type Dropdown. If you want a new type 
of Multi adding to the list, please let me know!  

 

Multi Fan Out - Displays a Multi Fan Out symbol. The 
user can select the type of Fan out. (Custom Fan outs 
can be added within Prod Lx Preferences) Within the 
OIP there are checkboxes for displaying the multi head 
Type, aswell as Cable Range circles.  

The user can scale the object using the scale field. 
Input a number greater than 1 for bigger, and smaller 
than 1 (e.g 0.5) for smaller 

Within Prod Lx Preferences the user can add custom 
Fan out Types, aswell as customise the cable lengths. 
They can also customise the colour of both the Fan 
out and Cable Range Circles.  
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Insert Pos Tag – Inserts a position/truss tag. The colour and Direction of arrow can be 
changed from the OIP menu, and all necessary fields can be filled in from the OIP. If no 
record called “Position Note” is present, when activated, this tool will automatically 
create the record and attach to every POS Tag object. All Fields are automatically filled 
in and updated when changed in the OIP. 

If the Show Weight field is checked, the plugin will calculate the weight any fixtures with the 
same Position as the exact name of the Position Note, aswell as make an estimation for cable.  

POS Tag can also take into account the weight of Truss, Vectorworks Hoists, and Lighting Pipe 
objects. You just need to make sure they have the correct position name associated with them. 

You can also choose wether to include or ignore each components weight from the total weight 
by unchecking the relavant box. 

Accounting for Cable weight can be turned off within the Prod Lx Preferences Menu.The formula 
used to calculate cable weight is: 

(TRS_weight * fixture_count) + (Spider_weight *(fixture_count /6 )) + (Soca_weight * 
(fixture_count / 6) * (truss_length / 1000)) 

Where TRS_weight = 1kg, Spider_weight = 2kg, Soca_weight = 0.52kg 

 

 

 

 

 

 

You can also display the Component weights that are making up the total by checking 
the “Show Weight Break Down” box. This will display all the component total weights 
below the Position Note 

The “Show Dual Units” Checkbox allows you to automatically show both Metric and 
Imperial weights side by side. To enter a new trim height you can either enter it in raw 
units for your documents unit type, e.g for a 10m trim with document units of MM you 
would enter “10000”. Alternatively you can just type “10m” and this will automatically be 
converted. Please note the only unit types that will be accepted are M, MM or Ft (‘). 

There is also a Scale field, should you wish to make the Position note Larger or smaller. 
It defaults to 1, numbers larger than one will increase the scale by a factor of that 
amount. Numbers smaller than 1 will decrease the size. 
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Pro Tip: You can use Spotlight Numbering to quickly enter squential truss names e.g 
‘Truss A’, ‘Truss B’ See below screenshot for an example of these settings. 
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Insert Sneak Snake – Inserts a Sneak Snake Symbol. All necessary fields can be filled 
in from the OIP. If no record called “Sneak Snake” is present, when activated, this tool 
will automatically create the record and attach to every POS Tag object. All Fields are 
automatically filled in and updated when changed in the OIP.  

 

 

 

 

 

 

DMX Note – Inserts a DMX Note to denote either the beginning or end of a DMX line. 
The Type, and direction of the note can be changed using the Type field in the OIP. 

 

 

 

 
PLX Motor FO – This displays a motor fan out symbol. The user can select what type of 
Fan out the Fan out is. (Custom Fan outs can be added within Prod Lx Preferences) 
Within the OIP there are checkboxes for displaying the multi head Type, aswell as 
Cable Range circles.  

Within Prod Lx Preferences the user can add custom Fan out Types, aswell as 
customise the cable lengths. They can also customise the colour of both the Fan out 
and Cable Range Circles.  
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Simple Motor – Tool for displaying simple 2d Motor Symbols on a plot. The User can 
set a Motor Label, chose the type and Department (which will colour the Motor 
Accordingly). There is also a checkbox to automatically display the XY co ordinates 
relative to the document origin.   
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TruckPack 

 
TruckPack is a series of tools that assist the user in drawing out their Truck Packs. The 

aim of this is both to ascertain whether the required will fit in the available space, but 
also to work out the easiest and most efficient pack BEFORE you’re actually having to 

load it! 
 

The tools are designed to allow the user to create their packs as quickly and efficiently 
as possible (because who wants to be spending their evenings drawing Trucks when 
they could be at the pub!)   To that end the plugins are designed to create your entire 

“Case” library from a Excel sheet of box dimensions, no need to manually create 
symbols for all your cases! There are then a number of drafting tools to really speed up 

the planning of your packs! 
 

For a deep dive into all the features check out this YouTube video: 
https://www.youtube.com/watch?v=xxcpv5S3_q8 
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TruckPack is made up of a number of Commands whose function is briefly outlined 
below. 

Create Box Symbol – Creates a single symbol to represent one 
type of Flight case.  When you run the command, you are presented 
by a dialog where you can fill in all the necessary dimensions of 
said case. The Symbol Name Field is the actual name of the 
Symbol within the Resource Browser and, with all VW Symbols, this 
name must be a unique name. 

Case Label is the Label that will be displayed on the box. 

The Orientation Field Defines what Orientation the Case is drawn in. 
Possible options for case orientation are: 

“On Wheels” -  Wheels on the floor, this is the default. 

“Tipped” -  Case is tipped on it’s end wheels to the back 

“Belgium” – Wheels point to the roof 

”'Wheels to Sky” - Wheels point to the roof 

“Side” – Case is tipped on it’s side with wheels to the back  

“Hinges” - Case is tipped on it’s side with wheels to the back 

NOTE The contents Tipped Field MUST have one of these above options in it, if 
anything else is entered into this field it will default to on it’s wheels. 

The Caster Checkbox specifies whether the case is drawn with casters or not. 

    

Tipped Belgium Side Wheels 
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Below is a screenshot showing how I have 
named each dimension this is consistent 
across ALL of the TruckPack commands. 
Note the Height is ALWAYS taken from 
the floor to the top of the box, so therefore 
INCLUDES caster height. (the Caster 
symbol used for my boxes is a simple 
generic caster Symbol. If you wish to use 
your own Caster Symbol simply make 
sure the symbol is located somewhere 
within the drawings symbol library, and 
then Go into Prod Lx Preferences > 
TruckPack  and change the name in the 
Caster Symbol Name Field to the name of 
your custom Symbol. 

 

 

 

 

 

Create Boxes from CSV – This command takes a CSV file, and creates a case symbol 
for every row within the CSV. 

 

The Column headers are all exactly the same as in the Create Box Command, and 
function in the same way, for instance the Tipped Field MUST say “Yes” or “Tipped” if 
you wish the box to be Tipped. The Weight field is not required and can be left blank if 
you wish.  

A word about units. When creating the cases TruckPack will use whatever Units you 
have your document set to. By Default I’d recommend working in mm as this is what 
TruckPack has been optimized for. HOWEVER if you want to use Imperial 
Measurements I recommend setting your drawing to Feet&Inches and then Specifying 
your dimensions in the format: 3’11” (3 foot 11 inches). If you are using mm or another 

TruckPack Case Dimensions Naming 
convention 
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metric measurement you shouldn’t specify units within the dimension fields, just make 
sure your units match the units within VW! 

NOTE –By default if a symbol with the name specified already exists that box will NOT 
be created. You can change this in Prod Lx Preferences so that it deletes any existing 
symbols. 

The quantity field is optional. If you do decide to add quantities to cases, when you run 
the command you will be asked if you wish to insert the cases onto the drawing. If the 
user selects Yes then the number of case symbols specified in the CSV will be inserted 
onto the drawing. 
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Update Box Dimensions – This dialog allows you to select a preexisting case and 
update it’s attributes. You can also set the Real World Confirmed Checkbox here to 
mark off cases as having had their dimensions confirmed in real life. 
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Insert Box Row – Inserts a “Block” of the same Case. You can either specify the case 
type, Number of Cases in a Row, Number of Rows and Row Type (Top, Bottom or 
Double Stacked) either from the OIP or from the Object insertion Properties window, 
which will bring up a dialog for you to select the default insertion properties.  

 

 

You can assign a Box Row object to a specific Truck using 
the Truck Field. If you insert a Box Row Object on top of a 
TruckBase object it will automatically populate this field 
with the Truck Name 

NOTE – because this is a Plug In Object this will act as 
one object, so after you insert it, it will still be one object, 
not individual cases, if you want to insert cases as 
individual symbols, use the Insert Boxes MENU 
command 

 

  



Prod Lx – Manual  V6.0.3 

  Tom Bexon 
  Tom@tb-lx.com 

Insert Box -  Works in a very similar way to Insert Box Row except instead of inserting 
all the cases as one Plug In Object it inserts them as individual symbols. When you run 
the Menu Command it will display a dialog where you can specify the Symbol you want 
to use, Total Boxes in the Row, Number of Rows and Row Type (Top, Bottom or Double 
Stacked) 
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TruckBase -  This Object is used for displaying the outline of Trucks. 
You can specify the name of Truck and the Dimensions from the OIP. 
There is also a checkbox where you can turn on or off a dimension tape along 
the side of the Truck. You can also specify whether this tape should be in Feet 
or Meters. 

A Note on the “look” of TruckBase: I have deliberately kept the 3d design very 
simplistic, to reduce unnecessary lines that slow what can be some quite big 
drawings.   
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Menu Commands 

Attribute Modifiers 

 

Copy Attributes to object – Copies the user specified Attributes from currently 
selected fixture. 

 

Shift Channel Num by X- Shifts the channel number of the selected units by the 
specified amount. Note: Decimals are not supported at this time, the channel number 
must be a whole number 

 

 

 

 

 

 

 

Count Objects Selected – Counts every 
Light/Truss/Plugin object/ Symbol you currently have 
selected, and summaries them in a pop up dialog.  

Refresh Objects – Refreshes all objects on the 
drawing. This can be very helpful if you’ve changed 
something and things haven’t updated. 

DMX Parameters Per Truss – Creates a worksheet displaying the total DMX count Per 
Position, aswell as Minimum Universe count 
per truss. Note: So as not to include 
Generics in the count any Lighting Device 
with a DMX footprint of 0 or 1 will be ignored 
from the count. You can modify how many 
channels are in a universe (by default it’s 
512) within the Prod Lx Preferences Menu 
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Flip Units- Flips a lighting Device by 180 degrees. The exact Criteria of which Lighting 
Devices are affected can be changed from Flip Units Preferences. 

 

Flip Units Preferences – Allows the user to select the 
criteria for which Lighting Devices are affected by the Flip 
Units command. The options are: 

Flip by Symbol name: This will flip any Lighting Device, 
where the underlying symbol contains a certain phrase. 
e.g if I had several lights where the symbol name was 
“Mac Viper Performance (Floor)” and I set the Symbol 
Name to be (Floor) any fixtures containing that phrase 
would be flipped, so if I also had some Auras called “Mac 
Aura XD Floor” they would NOT be affected. 

Flip by Layer: this either Flips all fixtures on the currently active Layer OR on a User 
Defined Layer. E.g If User Defined Layer Checkbox is selected, and the phrase I have 
entered is “Floor” every Lighting Device on the layer “Floor” will be flipped. 

Flip By Selected: Does exactly what it says on the tin, Flips all currently Selected 
Lighting Devices. 

 

Mains and DMX Requirements- Calculates the Total Power and Total DMX of all 
fixtures currently drawn in the active document. If the fixtures have a ‘Supply’ Field it will 
divide the fixtures by Supply. Hint if you want every fixture to be fed from the same 
supply use the ‘Set All Fixtures To Supply’ to quickly set all Supplies. 
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If you’re fixtures don’t have a Supply field you can go: File>Document 
Settings>Spotlight Preferences and then under Lighting Devices – Parameters tab you 
can add a custom field. 

 

 

Set All Fixtures To Supply- If the Fixtures have a custom field called ‘Supply’ this 
script will set every fixture to whatever name the user defines. To add a custom ‘Supply’ 
field to your spotlight fixtures go to: File>Document Settings>Spotlight Preferences and 
then under Lighting Devices – Parameters tab you can add a custom field, name it to 
‘Supply’ and make it a text field.  

 

You can now change the name of the ‘Supply’ field within Prod Lx Preferences. So if 
you have named your Supply field ‘Lx-Supply’ rather than ‘Supply’ you can modify the 
name within Prod Lx Preferences to match the spotlight name. 
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Create Custom AP TT Symbols 

This command is to be used in conjunction of with the AutoPlot Truss Tape Tools. What 
this command does is allows you to create a Custom Truss Tape Symbol for every 
Lighting Device in your active document. The base symbols from which the Truss Tapes 
are built are contained within the Vectorworks file “Prod Lx AP TT Base Symbols.vwx” 
which is located within the Prod Lx folder in the user Plug Ins folder.  

When you run the command you are presented with a dialog where you can select 
which base symbol to use for each Lighting Device.  

 

 

  

 

 

 

 

 

 

 

When you select a fixture in the left hand list it will display in the right, which base 
Symbol is currently selected. You can then select your preferred base Symbol or specify 
that you don’t want any symbol to be created for that fixture. 

You can also use the top dropdown to set all Lighting devices to use the same base 
Symbol. 

When you hit ok you are given an option to write the fixtures to the AP Sheet. If you 
select Yes this will add a line for each Lighting device into the “Truss Tape Labels 
Fields” worksheet. Prod Lx will check and see if it exists. If it doesn’t it will notify you, 
and you will have to re run the command after running the AutoPlot command “Edit 
Truss Tags Assign Wks”. 
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Patch 

Patch Fixtures from CSV - Imports Patch from CSV file and 
patches all corresponding fixtures. The fixtures in VW must 
already have channel numbers assigned to allow patching. This 
plug in will set the Universe/ Address of the fixture aswell as the 
DMX Qty. When you run this command a dialog will popup 
allowing you to select which column to use for which field. 

You can also use this tool to patch other attributes, such as 
Circuit Name and Number. You can also select up to two fields 
from any part of the spotlight Lighting Device record. 

One thing to note is that currently the mode cannot set text 
based modes, for instance if in your CSV file the mode field 
for a fixture is set to ‘ext’  

Having this tool support text based modes is very much 
on my To Do List and will hopefully be coming in a 
future release soon! 

 

Export Chamsys Patch- Exports a CSV of all fixture Patch and XYZ information for 
importing into Chamsys MagicQ Software Range. For information on importing this 
patch information into MagicQ please see here. 
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Export Patch- Exports a CSV of all patch sheet relevant information, for using with 
importing into Excel Patch Sheets. Includes 3 Users Fields, which are by default named 
Mode, Fixing and Rig Notes, however you can rename them by editing the worksheet. 
These relate to Spotlight User Fields. By Default they are: 

Mode: User Field 1 

Fixing: User Field 2 

Rig Notes: User Field 4 

In the next release there will be the option to edit which user field is assigned to which 
attribute, aswell as to rename these attributes. 
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Create POS Colours –Draws coloured rectangles over every Spotlight Hanging 
position with an associated POS Tag. It will set the larger rectangle colour to the “Colour 
1” field in the POS Tag object, and the smaller rectangle to ‘Colour 2’.  All Position 
rectangles are drawn on a new class and layer the name of which can be specified 
within the Prod Lx Preferences Menu, under the ‘Create POS Colour’ Tab. You can also 
specify whether, by default, the New layer is inserted at the top or bottom of your 
drawing’s layer stack. There is also an option to delete all current contents of the 
Position Colours Layer. By Default this is enabled and will delete EVERYTHING 
associated to the Position Colours Layer. 

 

Create Lifting Group Cols–Draws coloured rectangles over every SpotIight Hanging 
Position that has a corresponding Lifting Group assigned to it within the Position Tag. 
You can Specify the Class and Layer name, along with Opacity within Prod Lx 
Preferences under the Lifting Group tab. You can also specify whether, by default, the 
New layer is inserted at the top or bottom of your drawing’s layer stack. There is also an 
option to delete all current contents of the Position Colours Layer. By Default this is 
enabled and will delete EVERYTHING associated to the Position Colours Layer. 
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X Check 
Cross Check is a series of commands for flagging any errors that may have 
been overlooked within your drawing. 

 

Check Missing Spare Ways – This script will check for both unused spare ways, and 
incorrect spare ways within the drawing.  

The first check will return a list of all the currently unused Multi Ways where at least 1 
way of the multi has already been assigned to a lighting device.  

Additionally if you have a spare way object/ lighting device (such as the one below) 
within your resource manager you will be given the option to insert a spare way object 
for each missing spare way above the corresponding Multi Fan Out object. 

 

Secondly this command will check for any spare way objects already inserted on the 
plan and check if any of them are in fact actually in use. If any are in use a worksheet 
will be returned with a list of them. 
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Every Fixture Has Channel– This Script will first check that every fixture has a 
Channel number assigned to it. If there are fixtures with a blank channel field, you will 
be presented by this dialog: 

 

 

 

 

Click Next to cycle through any fixtures missing Channel numbers. The script will focus 
you’re screen on each fixture as you cycle through. You can then Enter a new Channel 
number into the Center text box. Once you are done click Close. The script will then 
bring up a worksheet showing any potential errors in channel numbering. The criteria it’s 
looking for are: 

Potentially Skipped Channels in a run of numbers. For instance if you have some 
fixtures numbered 1 , 2 , 3,  5 , 6, 7, 8, 9, 10 The script will flag the fact you have 
potentially missed out Channel 4 putting the rest of you’re numbers out of sequence. 
Something to note so as to stop the script throwing hundreds of potential wrong 
numbers it will only flag errors where the gap between ranges is less than 5 e.g 1-5 9-
15 it would flag 6, 7, 8 are missing but 1-10 and 16-20 wouldn’t raise any errors 

Duplicate Channels. Any Channel numbers that have been used more than once.  
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Of course for all these criteria you may have quite deliberately wanted to have duplicate 
channel numbers for fixtures, or wanted to skip channel 4 so the script just highlights 
potential errors and you can then decide if they are actual problems or not! 

 

 

 

 

 

 

 

 

 

 

 

Fixture Have POS- Checks if every Fixture has a position and creates a WS of any 
fixtures missing a position. Note this script has no way of knowing if a fixture has a 
correct position assigned to it, merely that it has A position of some description 
assigned to it  

 

 

 

 

 

 

Do DMX and Soca match Looms- Check that the Labels within both Looms and 
Sneak Snakes match up for both Extension and Feeder Looms. To tell Prod Lx a loom 
is an extension or feeder loom select the loom object and you will find a dropdown field 
called ‘useage’.  

The Script also compares what DMX cables are in the Looms/ Sneak Snakes against 
DMX Notes to check that every DMX Note is contained within the Looms aswell as all 
DMX’s assigned to looms have a DMX note somewhere on the plan. It also will cross 
check any Autoplot Multicables you may have drawn on the plan and makes sure they 
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are all contained within a loom somewhere. Obviously because the script can’t know all 
you’re intentions it may throw some things up as errors, such as maybe a Soca not 
being included in an extension loom, which you know not to be the case, but atleast you 
can then decide what might be genuine errors and what aren’t!  

 

 

 

 

 

 

 

 

Worksheets 

Export XXX WS – Recalculates and Exports the specific worksheet to CSV. This will be 
saved in the same folder as the active drawing. If the Worksheet does not exist, this 
command will automatically make it. Important note – You must save your drawing 
somewhere before using these commands. Otherwise they will throw up an error stating 
access is denied! 

ReCalculate all WS – Recalculates ALL Worksheets in the active document.  

 


